telegrambot

Библиотека для взаимодействия с Telegram Bot API

Пример


Бот = Новый ТелеграмБот;
Бот.УстановитьТокенАвторизации("ТВОЙ_ТОКЕН_БОТА");
Бот.УстановитьВебхук("ТВОЙ_АДРЕС_ДЛЯ_ХУКОВ");

///

ОбъектЗапрос = ПарсерJSON.ПрочитатьJSON(ТекстТелаЗапроса);
      
Если ОбъектЗапрос["message"] <> Неопределено Тогда
            
    ТекстСообщения = ОбъектЗапрос["message"]["text"];
    ПолучательИД = ОбъектЗапрос["message"]["chat"]["id"];

    Если ТекстСообщения = "/start" тогда
                  
        ТекстСообщения = "Привет, в низу меню для навигации";       
        Сообщение = ТелеграмАПИ.НовоеСообщение(ПолучательИД, ТекстСообщения);
        ТелеграмАПИ.ДобавитьКлавиатуру(Сообщение, ГлавноеМеню());
        Результат = Бот.Отправить(Сообщение); 
            
    КонецЕсли;      
            
КонецЕсли; 

///

Ответ = Новый РезультатДействияСодержимое();
Ответ.КодСостояния = 200;
Ответ.ТипСодержимого = "application/json;charset=UTF-8";
Ответ.Содержимое = Результат["ok"];
      
Возврат Ответ;

Функция ГлавноеМеню()

	КомандаКаталог = ТелеграмАПИ.НоваяКнопка("Каталог");
	КомандаКорзина = ТелеграмАПИ.НоваяКнопка("Корзина");

	ПервыйРяд = ТелеграмАПИ.ПолучитьРядКнопок(КомандаКаталог, КомандаКорзина);

	КомандаНашТелегон 	 = ТелеграмАПИ.НоваяКнопка("Наш телефон");
	КомандаЛичныйКабинет = ТелеграмАПИ.НоваяКнопка("Личный кабинет");

	ВторойРяд = ТелеграмАПИ.ПолучитьРядКнопок(КомандаНашТелегон, КомандаЛичныйКабинет);

	МассивРядов = ТелеграмАПИ.ПолучитьМассивРядовДляКлавиатуры(ПервыйРяд, ВторойРяд);

	Возврат ТелеграмАПИ.ПолучитьКлавиатуру(МассивРядов);

КонецФункции


На текущий момент реализовано получение данных только через WebHooks

Доступные версии пакета

0.0.4
Изменен: 02.01.2019 19:48:30
В разработке

Репозиторий

https://github.com/oscript-library/telegrambot

Актуальная версия

telegrambot-0.0.4